bug in first line of addText

Aug 10, 2011 at 1:10 PM

There seems to be a bug when adding text via addText() and there will be a white space before the text starts. This is only on the first line, from the second line it is shown correct again is against the left border.


Example of a letter:
 
---------------------------------------------------
// get text form database

$text_letter = "Company Name
Streetname plus number
City plus postal code
Country code



Date: 10 august 2011



Dear Customer,

Here is the information you have asked for. Here is the information you have asked for. Here is the information you have asked for. Here is the information you have asked for. Here is the information you have asked for.


Regards,

Theo";


// add this to section

addText($text_letter);

This will be saved and printed as:


         Company Name  <---- here the first line is indented
Streetname plus number
City plus postal code
Country code



Date: 10 august 2011



Dear Customer,

Here is the information you have asked for. Here is the information you have asked for. Here is the information you have asked for. Here is the information you have asked for. Here is the information you have asked for.


Regards,

Theowil
---------------------------------------------------

This is even more of a problem when the different sections (address, date, letter text, ending) are put separately in the section via addText(), then each part will start with a white area, like an indent.

Is this a known problem or is there some solution or work around for this?


Thanks,

Theo

Aug 11, 2011 at 3:09 PM

Not a known problem. Save the created Word doc as a .zip file. Then unzip it and examine the .xml file. Look to see what formatting is there that creates the white space. Perhaps that knowledge will help.